Elite Limited - Elite Telephone Switchboard – Incident details

Elite Telephone Switchboard

Resolved
Operational
Started 10 months agoLasted about 4 hours

Affected

Customer Portals, Tools & Contact

Major outage from 8:05 AM to 12:23 PM

Telephone Switchboard

Major outage from 8:05 AM to 12:23 PM

Updates
  • Resolved
    Resolved

    We are marking this as resolved now as we have had communication from our upstream that they have now brought back online our services.

  • Identified
    Identified

    We have been informed by our upstream voice provider that they are suffering an issue and our main lines are currently experiencing an issue. We will update in due course.

    In the meantime our normal ticket and live chat channels remain unaffected.